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Activities Included 
Create a Site Definition 
 
New Document & Page Properties 
 
Table Based Design Layout 
 
Populating the page: Navigation, Header, News, Footer 
 
Creating your first template 
 
Creating site pages and applying your template 
 
Adding Content to your pages 
 
Updating your template 
 
Spending Time fixing up your site 
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Activity #1 – Create a Site Definition 
1. Open Dreamweaver 
2. Watch “Creating a site definition in dreamweaver 8” located on the CMS 

training website. 
3. In dreamweaver : 

a. Click on Site>New Site 
b. Name your site CMSXX 
c. http address: http://www.humboldt.edu/~cms/training/cmsxx. Click 

Next 
d. Server Technology. No. Click Next 
e. Browse to find you site folder. Click Next 
f. Choose none for remote server. Click Next 
g. Click Done 

 
 

Activity #2- New Document & Page Properties 
1. Click File > New. 
2. Select Basic Page > Highlight HTML. Click Create 
3. Click on Design Mode 
4. Right Click within the document space. Select Page Properties. 
5. Under the Appearance Category in the Page Properties Dialogue choose 

the following: 
a. Page Font- Ariel 
b. Size- 12 
c. Text Color- Black 
d. Leave the rest blank 

6. Select the Links category 
a. Link Color- Choose dark green or type #006600 
b. Visited links - #006600 
c. Rollover Links- #CCCCCC 
d. Active Links- #006600 
e. Underline Style – Show underline only on rollover 

7. Select the Headings category 
a. Heading 1 – 36 px, Color - #006600 
b. Heading 4 – 14 px, Color - #999999 

8. Select the Title/Encoding 
a. Title- Dreamweaver I: Web Design For The Workplace 

9. Click OK 
10. Note: You can change page properties at anytime.  Property changes will 

have an effect on the entire page and/or site. 
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Activity #3- Table Based Design Layout 

1. Make sure that you are working in the layout panel group.  Select from the 
dropdown in the upper left of the dreamweaver workspace. 

2. Click Insert > Table. 
3. The table dialogue pops up.   

a. Rows – 4 
b. Columns – 3 
c. Table width – 90 % 
d. Cell padding – 5 
e. Cell Space – 0  
f. Click OK 

4. Select the top row by placing the mouse cursor in the top right cell and 
dragging to the top left cell. 

a. Merge the cells by clicking Modify > Table> Merge Cells 
b. The top row should now be one cell.  This will become your header. 

Type “Header” 
5. Please merge the bottom row of cells so that the bottom row mirrors the 

top.  This row will be your footer. Type “Footer” 
6. Merge the middle rows in the left column.  Highlight the cells and click 

Modify > Table > Merge Cells. Type “Navigation” 
7. Merge the center column. Type “Content” 
8. Merge the right column. Type “News” 
9. You now have the basic foundation of your webpage.  Let’s go further. 
10. Select the entire table by clicking on the table tag located below your 

document and just above the properties panel. 
11. With the table selected please do the following: 

a. In the properties panel 
b. Align- Center 
c. Brdr color - #666666 
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Activity #4- Populating the page: Navigation, Header, News, Footer 
1. Click inside the header row. 

a. Type Humboldt State University hit shift+enter 
b. Type Department of Walking and Talking 
c. Select Humboldt State University apply the following text 

properties: 
i. Size- 36 px 
ii. Color- Dark Green or #006600 

d. Select Department of Walking and Talking and apply the following 
text properties: 

i. Size- 18px 
ii. Color- #666666 

e. In the properties panel you will notice that you can further format 
cell/row properties.   

i. Choose a background color of #CCCCCC 

 
2. Click inside the Navigation Cell. 

a. Hit Shift+Enter after “Navigation” 
b. Type the following categories: 

i. Home 
ii. Map 
iii. Fast Facts 
iv. Contact Us 

c. Highlight “Navigation” and change the color to #006600 
d. Bold “Navigation” 
e. With “Navigation” still selected right click choose Style >Underline. 
f. Highlight each of the category items and assign the following links: 

i. Home – ../index.html 
ii. Map – ../map.html 
iii. Fast Facts – ../fast_facts.html 
iv. Contact Us – ../contact.html 
v. Note: these links are known as relative links as they point to 

files all residing in the same folder.  Absolute links contain 
the entire website url. E.g. 
http://www.humboldt.edu/~cms/training/dreamweaver/cmsxx/
index.html 

g. Click inside the navigation cell and apply the following cell 
properties: 

i. Vertical Placement – Top 
ii. Horizontal Placement – Left 
iii. Bg color - #FFFFCC 
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3. Click inside the “News” Cell and format it to look identical to the Navigation 

Cell 
a. Remember to change the Vertical placement to top and Horizontal 

placement to left. 

 
4. Click inside the “Footer” Cell and create the following link in a horizontal 

line.  Page footers are important because they offer an alternative to the 
side navigation located at the top of the page.  This is good for pages with 
a lot of text or images.  See image below for an example. 

 
5. Congratulations! You have just created your first table based design in 

dreamweaver.  In the next activity you are going to learn how to put this 
design to work. 

Activity #5 – Creating your first template. 
1. With your page still open click File > Save as Template. 
2. When the Template dialogue opens type Master in the save as field.  You 

may enter a description of the template however this is not necessary. 
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3. Note: If you want to make site wide changes in the future all you have to 
do is make a change to your template.  This is going to become clearer as 
we begin creating site pages.  

4. Click inside the Content cell.  Please apply the following properties to this 
cell. 

a. Horizontal Placement – Left 
b. Vertical Placement – Top 
c. Delete the work “Content” 

5. We are now going to apply an editable region to your template.  Reasons 
as to why we are doing this will become clear in following activities. 

a. Click > Insert > Template Objects > Editable Region 
b. Give the new editable region a name : Content 
c. Click OK 

 
6. If done correctly your template should look exactly like the image above. 
7. Save your template. (ctrl+s) 
8. Great Work.  You are now ready to begin building your site pages.  We will 

becoming back to make adjustments to your template but for now please 
close it. 
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Activity #6 – Creating site pages and applying your template 
1. Click File > New.  Select Basic Page > HTML 
2. When your page opens please do the following: 

a. Click Modify > Templates > Apply Template to Page. 
b. Choose your template. 
c. Notice that the template you have just created is not applied to the 

page.  You will also notice that the only place that you can type in 
or make changes is within the editable region that you created.  All 
other changes must be done within the template. 

d. In the editable region please type Home. Left Justified. 
e. Save your page. 

i. File Save > index.html 
3. Please create the following pages using the process above: 

a. map.html 
b. fast_facts.html 
c. contact.html 

 

Activity #8 – Adding Content to your pages 
1. In the files panel open index.html 

a. Open the word file titled “Dreamweaver I” 
b. Locate the “Home Page” text and copy it. 
c. Paste the text inside the editable region. 
d. Place your cursor after the last word on line one and do the 

following: 
e. Click Insert > Image.  Locate the hsu 6333.jpg  image in your 

images folder. Click OK 
f. Select the image and resize it to an appropriate size (249px x 

156px). 
g. Under the Align drop down choose ‘Right.” 
h. Move the picture to a well placed section of your page. 
i. Save your page. 

2. Open map.html 
a. Copy the Map information from the word document and paste it into 

the editable region. 
b. Bold the following: 

i. Library 
ii. Human Resources 
iii. Art Department 
iv. Music Department 
v. Walking Directory- 18px, color #006600 

c. Highlight all departments and urls and make them right justified. 
d. Click Insert > Image.  Select the hsu_map.jpg from the images 

folder. 
e. Align the image “left” 

Page 7 of 13 



CMS PMO 
Dreamweaver I: Web Design for the Work Place 
Activities 

f. Move the image up just left of Library. 
g. Highlight each url on the page and create links out of them.  Use 

the url as your link.  Remember to type http:// prior to each link. 
h. Save your page. 

3. Open contact.html 
a. Copy and Paste the contact information from the word document.  

Format the information like the image below. 

 
 

4. Open fast_facts.html 
a. Copy the Fast Facts information from the word document and paste 

it into the editable region of your page. 
b. Now go through the pasted information and apply the Heading 4 

formatting to each of the section heads.  E.G. Student Ethnicity. 
c. Highlight Fast Facts and format it: 18px, color- #006600 
d. Save your page. 

5. Congratulations.  You have now just created four web pages based on 
your template.  Because we have already link the pages together when we 
built the template.  Your webpage are now accessible to one another via 
the navigation.   

 

Page 8 of 13 



CMS PMO 
Dreamweaver I: Web Design for the Work Place 
Activities 
 
 

Activity #7 – Accessibility check, preview in browser 
1. Open index.html 
2. Hit the f12 key to preview your page in an internet browser.   
3. Once open click on all links to make sure the are working and that you 

navigate successfully around your site. 
4. If successful return to Dreamweaver. 

Activity #8 – Putting and Getting Files using ftp. 
1. Putting/uploading files to a web server is how web pages are published to 

the internet.  By placing files on web accessible server your pages 
become viewable by anyone with an internet connection. 
Getting/downloading files is the process of grabbing files from the web 
server and placing them onto your local machine. 

2. In order to Put or Get files you will need to establish and ftp connection via 
the site definition process.  We began this process in the beginning of this 
class.  However, we did not establish an ftp connection.  Please do the 
following. 

3. Click Site >  Manage Site > Select your site and click edit. 
4. Enter the HTTP Address of your site. 

a. http://www.humboldt.edu/~cms/training/web/cmsxx 
b. Click Next 
c. No, you do not want to use a server technology. 
d. Click Next 
e. Keep the next screen as it is.  Click Next 
f. Under Sharing Files please fill in the options like the image below.  

Replace cmsxx with your assigned number. 
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g. Test your connection.   
h. Click Next 
i. Enter the information in the screen shot below.  

i. Replace public_html with ~cms 
ii. Replace cmsxx  with your number. 

 

 
 

* Be sure to test your url.
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5. Now that you have successfully established an ftp connection with 
the web server you can now put/upload your files. Please do the 
following: 

a. In the files panel located in the bottom right over your dreamweaver 
workspace select all files in your site and click on the blue “Put” 
arrow. 

b. Your files will be transferred to the web server.  Once finished open 
your browser and check to see if you site is “live.” 

c. Type. http://www.humboldt.edu/~cms/training/web/cmsxx 
 

Activity #9 – Updating your template 
1. Any time you would like to make changes site wide you are going to want to 

make these changes to your template. 
a. In the news column please enter the following information: 

i. July 11- Walking tour of the HSU Dorms 
ii. July 13- A Talking tour around Redwood Bowl 

b. Save your template and update all your files. 
c. “Put” your updated files onto the web server. 

 
Activity #10- Spending Time fixing up your site. 

1. Dreamweaver is a fun and powerful communications program.  Now that you 
have had an introduction the best and only way to get better is to practice and 
explore.  With the time we have left I encourage you to work on making your 
site your own.   
2. Change your background colors, cell sizes, images, etc…. 
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From the Humboldt State University Web Office Website 
 
Definition of a Reasonably Accessible Web Site: 
A reasonably accessible website is one that satisfies all of the following checkpoints. These 
checkpoints were taken from the World Wide Web Consortium’s (W3C) Web Accessibility 
Initiative (WAI) Priority 1 checkpoints as specified in the Web Content Accessibility Guidelines 1.0 
and the Section 508 Web-Based Intranet and Internet Information and Applications. 

Checkpoints: 

1. Provide a text equivalent for every non-text element (e.g., via “alt”, “longdesc”, or in 
element content). This includes: images, graphical representations of text (including 
symbols), image map regions, animations (e.g., animated GIFs), applets and 
programmatic objects, ascii art, frames, scripts, images used as list bullets, spacers, 
graphical buttons, sounds (played with or without user interaction), stand-alone audio 
files, audio tracks of video, and video.  

2. Ensure that all information conveyed with color is also available without color, for 
example from context or markup.  

3. Clearly identify changes in the natural language of a document’s text and any text 
equivalents (e.g., captions).  

4. Organize documents so they may be read without style sheets. For example, when an 
HTML document is rendered without associated style sheets, it must still be possible to 
read the document.  

5. Ensure that equivalents for dynamic content are updated when the dynamic content 
changes.  

6. Until user agents allow users to control flickering, avoid causing the screen to flicker.  

7. Use the clearest and simplest language appropriate for a site’s content.  

8. Provide redundant text links for each active region of a server-side image map.  

9. Provide client-side image maps instead of server-side image maps except where the 
regions cannot be defined with an available geometric shape.  

10. For data tables, identify row and column headers.  

11. For data tables that have two or more logical levels of row or column headers, use 
markup to associate data cells and header cells.  

12. Title each frame to facilitate frame identification and navigation.  

13. When electronic forms are designed to be completed on-line, the form shall allow people 
using assistive technology to access the information, field elements, and functionality 
required for completion and submission of the form, including all directions and cues.  
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14. Ensure that pages are usable when scripts, applets, or other programmatic objects are 
turned off or not supported. If this is not possible, provide equivalent information on an 
alternative accessible page.  

15. When a web page requires that an applet, plug-in or other application be present on the 
client system to interpret page content, the page must provide a link to a plug-in or 
applet.  

16. Until user agents can automatically read aloud the text equivalent of a visual track, 
provide an auditory description of the important information of the visual track of a 
multimedia presentation.  

17. For any time-based multimedia presentation (e.g., a movie or animation), synchronize 
equivalent alternatives (e.g., captions or auditory descriptions of the visual track) with the 
presentation.  

18. A method shall be provided that permits users to skip repetitive navigation links.  

19. If, after best efforts, you cannot create an accessible page, provide a link to an alternative 
page that uses W3C technologies, is accessible, has equivalent information (or 
functionality), and is updated as often as the inaccessible (original) page. 
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